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License Agreement
READ CAREFULLY BEFORE INSTALLING THE MINISOFT SOFTWARE APPLICATION:
CUSTOMER: THE MINISOFT SOFTWARE APPLICATION (“PRODUCT”) THAT YOU PURCHASED CONTAINS COPYRIGHTS, TRADE SECRETS, TRADE MARKS, AND 
OTHER INTELLECTUAL PROPERTY RIGHTS BELONGING TO MINISOFT, INC. (“MINISOFT”), HAVING ITS PRINCIPAL OFFICES LOCATED AT 1024 FIRST STREET, 
SNOHOMISH, WASHINGTON, 98290, U.S.A. THE PRODUCT MAY BE INSTALLED, COPIED, DISPLAYED, EXECUTED, PERFORMED, OR USED IN ANY OTHER FASHION 
ONLY IN ACCORDANCE WITH THE TERMS OF THIS LICENSE AGREEMENT (“AGREEMENT” OR “LICENSE”). THE TERMS “YOU” OR “YOURS” ARE SOMETIMES USED 
HEREIN AND MEAN RESPECTIVELY CUSTOMER OR CUSTOMER’S. 
SOMETIMES EACH OF MINISOFT AND CUSTOMER IS REFERRED TO HEREIN AS A “PARTY,” AND SOMETIMES THEY ARE COLLECTIVELY REFERRED TO AS THE 
“PARTIES.”
YOU MAY NOT INSTALL, COPY, DISPLAY, EXECUTE, PERFORM OR USE IN ANY OTHER FASHION THE PRODUCT EXCEPT IN ACCORDANCE WITH THE TERMS AND 
CONDITIONS OF THIS AGREEMENT. IF YOU INSTALL, COPY, DISPLAY, EXECUTE, PERFORM OR OTHERWISE USE ANY PART OF THE PRODUCT, YOU ARE DEEMED 
TO HAVE ACCEPTED AND YOU ARE BOUND BY ALL THE TERMS AND CONDITIONS OF THIS MINISOFT LICENSE AGREEMENT (“AGREEMENT”). IN ORDER TO USE 
THE PRODUCT, YOU MAY BE REQUIRED TO OBTAIN A UNIQUE CODE OR CODES FROM MINISOFT TO ENABLE INSTALLATION, COPYING, DISPLAY, EXECUTION, 
PERFORMANCE AND OTHER USE OF THE SOFTWARE PRODUCT.
IF YOU DO NOT ACCEPT AND AGREE TO THE TERMS AND CONDITIONS OF THIS AGREEMENT, YOU ARE PROHIBITED FROM INSTALLING, COPYING, DISPLAYING, 
EXECUTING, PERFORMING, OR USING IN ANY OTHER FASHION THE PRODUCT. VIOLATION OF THIS AGREEMENT (1) CONSTITUTES INFRINGEMENT, 
MISAPPROPRIATION AND CONVERSION OF MINISOFT’S COPYRIGHTS, TRADE SECRETS, AND OTHER INTELLECTUAL PROPERTY RIGHTS, (2) WILL SUBJECT 
THE INFRINGER TO SIGNIFICANT CIVIL LIABILITIES FOR DAMAGES (INCLUDING WITHOUT LIMITATION STATUTORY DAMAGES) AND OTHER REMEDIES AND 
LIABILITIES, AND (3) MAY CONSTITUTE VIOLATION OF CRIMINAL LAWS.
IF A CUSTOMER IS PURCHASING AN UPGRADE FOR AN EARLIER VERSION OF THE PRODUCT, THEN THIS AGREEMENT SHALL SUPERSEDE THE TERMS AND 
CONDITIONS OF THE LICENSE AGREEMENT THAT APPLIED TO THE EARLIER VERSION AS TO THE USE OF THE UPGRADE PRODUCT AS OF THE DATE OF 
INSTALLATION OF THE UPGRADE.
NOW, THEREFORE, in consideration of the foregoing provisions and the terms and conditions herein contained and for other good and valuable consideration, the 
receipt and sufficiency of which are hereby acknowledged, the following terms and conditions apply:
A. License Grants
1. Upon MINISOFT’s receipt from the Customer of the one-time license fee and further subject to the other terms and conditions herein, MINISOFT grants the Customer 
a non-exclusive and non-transferable perpetual license: (a) to install and use the Product on only one host computer or business server in the Customer’s business 
organization; and (b) to install the client portion of the Product on a network server for access by more than one personal computer and on any personal computer client 
accessing the host server program. 
2. You may not: (a) allow access to or use of the Product to anyone outside of your organization; (b) decompile, reverse engineer, decrypt, disassemble, or otherwise 
attempt to copy or replicate the source code; (c) modify or translate those portions of the Product that are provided in an object or source code form, or alter, merge, 
modify, reverse engineer or adapt the Product in any way including disassembling or decompiling; (d) copy, loan, rent, lease or sublicense, assign, convey, sell, 
mortgage, pledge, dispose or in any other manner transfer to a third-party any part of or all of the Customer’s rights and obligations under this Agreement or in the 
Product; or (e) otherwise copy, distribute, rent, loan, disseminate, publish, sell or transfer any portion of the Product in any way inconsistent with or contrary to the 
terms and conditions of the Agreement. 
3. Any attempt to violate any prohibitions described in this Agreement shall be considered a material breach of this Agreement, and no attempt to violate section 2(c) or 
2(d) in the immediately preceding paragraph shall have any effect, and any prohibited act described therein shall be void and of effect if made by the Customer.
4. You may make one copy of the Product for use as a backup copy (the “Copy”) provided that: (i) the Copy includes all notices of copyright and all other proprietary 
rights appearing in and on the Software Product; (ii) the Copy and the original Product are not in use at the SAME time; (iii) Customer establishes a procedure for 
accounting for the Copy at all times; and (iv) Customer destroys or returns to MINISOFT the Copy when it is no longer required or when the license grants made 
hereunder are terminated for any reason, whichever occurs first.
5. This Agreement grants to the Customer a license for use of the Product on the terms and conditions set forth in this Agreement; and (ii) the Customer may not install, 
copy, perform, execute, display, or use in any other fashion the Product except in accordance with the terms and conditions of this Agreement. By any use of any 
element of the Product, the Customer shall be deemed to have accepted and be bound by all the terms and conditions of this Agreement.
6. MINISOFT retains and reserves all rights to the Product. Nothing contained herein shall be deemed to convey to the Customer any title to, or an ownership interest 
in, the Product or any of the intellectual property rights contained in the Product. Upon termination of this Agreement, all rights granted to the Customer herein shall 
automatically revert to MINISOFT.
B. Termination
The license grants made hereunder shall automatically terminate on the date of any breach by the Customer of any of the terms and conditions of this Agreement. In 
any such termination, you shall discontinue using the Product. You further agree to return the Product to MINISOFT or destroy all components of the Product and to 
certify in writing that the Product is no longer in use and that you have kept no copies of the Product. In any such termination of the license grants, none of MINISOFT’s 
rights in law or equity shall be barred, discharged, released, or otherwise impaired by such termination, and MINISOFT reserves all such rights described herein.
C. Confidential Information
The Product also contains MINISOFT’s commercially valuable, proprietary and confidential information and trade secrets (collectively “Confidential Information”). 
You are obligated to preserve and hold in confidence any Confidential Information and may not use any of it except in accordance with the terms and conditions of 
this Agreement. Confidential Information shall not include what is already public at the date of its disclosure or what later becomes lawfully public through no fault or 
responsibility of the Customer.
D. Limited Warranties and Limitations on Damages and Remedies.
1. Only the limited warranties expressly described in this section are made to the Customer purchasing this Product. No warranty of any kind, whether express or 
implied, is made to any third-party or other transferee or successor of the Customer.
2. MINISOFT warrants that it has the right to grant the licenses contained in this Agreement.
3. MINISOFT warrants that this product will execute its programming instructions when properly installed on a properly configured computer for which it is intended. 
MINISOFT makes no warranty of any kind, implied or express, that the Product will meet Customer’s requirements or that the Product will be uninterrupted or error-free
4. MINISOFT, Inc. warrants the media upon which this Product is recorded to be free from defects in materials and workmanship under normal use for a period of 90 
days from the date of purchase. During the warranty period MINISOFT will replace media that prove to be defective. Customer’s exclusive remedy for any media that 
proves to be defective shall be to return the media to MINISOFT for replacement.
5. MINISOFT’ only obligation, liability and/or remedy, with respect to the warranties set forth in this Agreement shall be one of the following, which MINISOFT shall 
have sole discretion to choose: (1) as described above, to provide replacement media (whether in the form of the current release or otherwise) for the Product; (2) to 
replace, without charge, the Product with a functionally equivalent software product; or (3) to refund the applicable license fees paid to MINISOFT by Customer. 



These are the sole and exclusive remedies for any breach of warranty.
6. MINISOFT shall have no obligation, liability or any other kind of responsibility for the costs of restoring any destroyed or defective data, installation of replacement 
media, or software conversion work made necessary by replacement media, even if MINISOFT had been specifically informed by Customer of the possibility or 
probability of any such consequences. During the ninety (90) days warranty period for the media, MINISOFT will replace, without charge, on an exchange basis, any 
media which is not as warranted. Customer must return the defective item postpaid to MINISOFT, postmarked within the time period stated above. Customer must 
either insure the defective item being returned or assume the risk of loss or damage in transit. Any claim under the above warranty must include a copy of Customer’s 
receipt or invoice or other proof of the date of delivery.
7. Year 2000 Warranty. MINISOFT warrants that the Product will accurately process date/time data (including, but not limited to, calculating, comparing, and 
sequencing) from, into, and between the twentieth and twenty-first centuries, and the years 1999 and 2000 and leap year calculations, in accordance with the Product’s 
documentation BUT ONLY to the extent that other technology and systems (e.g., software and operating systems, hardware and firmware) used in combination with 
the Product properly exchanges date/time data with it. In addition to the limitations of liability and remedies described above in this Section, the Year 2000 warranty 
made herein is made only for ninety (90) days after the date of delivery of the Product and only if any noncompliance is discovered and made known to MINISOFT in 
writing within such ninety (90) days. The Year 2000 warranty expires after such ninety (90) day period and shall not extend to any events occurring after the expiration 
date. 
8. MINISOFT makes no other warranty, expressed or implied, with respect to the Product. 
9. NOTICE: THE WARRANTIES, OBLIGATIONS AND LIABILITY OF MINISOFT AND THE RIGHTS AND REMEDIES OF CUSTOMER SPECIFICALLY SET FORTH IN THIS 
AGREEMENT ARE THE CUSTOMER’S EXCLUSIVE REMEDIES. MINISOFT DISCLAIMS, AND CUSTOMER HEREBY WAIVES, DISCHARGES AND RELEASES MINISOFT, 
ITS OFFICERS, DIRECTORS, EMPLOYEES AND AGENTS, FROM ANY AND ALL (1) OTHER WARRANTIES, OBLIGATIONS, OR LIABILITIES AND (2) RIGHTS, CLAIMS, 
CAUSES OF ACTIONS, EXPRESS OR IMPLIED, ARISING BY LAW OR OTHERWISE IN CONNECTION WITH, REGARDING, OR ARISING FROM THE PRODUCT OR 
ANY RELATED SOFTWARE, TANGIBLE OR INTANGIBLE ITEMS OR SERVICES PROVIDED UNDER THE AGREEMENT (INCLUDING, WITHOUT LIMITATION, ALL 
DOCUMENTATION SUPPLIED WITH THE PRODUCT). THE WAIVER, DISCHARGE AND RELEASE INCLUDE, BUT ARE NOT LIMITED TO: (1) ANY IMPLIED WARRANTY 
OF MERCHANTABILITY OR FITNESS FOR A SPECIFIC PURPOSE; (2) ANY IMPLIED WARRANTY ARISING FROM COURSE OF PERFORMANCE, COURSE OF DEALING, 
OR USAGE OF TRADE; AND (3) ANY OBLIGATION, LIABILITY, RIGHT, CLAIM, OR REMEDY, WHETHER IN TORT, CONTRACT, OR OTHERWISE. IN NO CASE SHALL 
MINISOFT BE LIABLE FOR ANY INCIDENTAL, INDIRECT, SPECIAL, CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, LOSS OF USE, REVENUE, 
PROFIT, OR DATA), PUNITIVE DAMAGES, EXEMPLARY OR OTHER STATUTORY DAMAGES, EXPENSES, COSTS (INCLUDING ATTORNEY FEES). IN ADDITION, IN NO 
CASE SHALL MINISOFT’S LIABILITY EXCEED THE FEES PAID BY CUSTOMER FOR THE PRODUCT.
E. Updates
Customer is entitled to updates and enhancements to licensed software if under a current Minisoft software update and subscription service. The cost of the update and 
subscription service will be 20% of the purchase price of the licensed software. The update and subscription service is for twelve (12) months and can be renewed at the 
customer’s discretion. 
F. Support Services
A customer that has purchased annual support entitles them to any and all software updates for their licensed product(s) as well as technical support via phone and 
email. Software Updates are available from our web site, www.minisoft.com. Included with the purchase of support is the use of our Toll Free 800 number, and support 
email. Days and Hours of support coverage are Monday through Friday 7:30am (Pacific) until 5:00pm (Pacific).  When support is purchased or renewed, an update 
may be downloaded from the Minisoft Website. In cases where support has expired, back-support is charged to bring the support account current. Any supplemental 
software code provided to you as part of the Support Services shall be considered part of the SOFTWARE PRODUCT and subject to the terms and conditions of this 
License Agreement. 

G. Miscellaneous
1. Governing Law. This Agreement is made for the sole benefit of the parties hereto, and there are no third party beneficiaries to this Agreement. This Agreement shall 
be interpreted under the laws of the State of Washington, notwithstanding the application of any jurisdiction’s choice-of-law rules to the contrary.
2. Independent Contractors. No agency, partnership, joint venture, or employer-employee relationship is created hereby, and neither party nor any of its agents or 
employees shall have any authority of any kind to bind the other party in any respect whatsoever. Each party is an independent contractor to the other party.
3. No Assignment by Customer. This Agreement shall be binding upon and inure to the benefit of MINISOFT and any successors and assigns. Customer shall have no 
right to assign or otherwise transfer its rights or obligations under this Agreement except with the prior written consent of MINISOFT, which MINISOFT in its sole 
discretion and for any reason or no reason provide or withhold.
4. Entire Agreement. This Agreement contains the complete understanding between the parties and shall as of the date the Product is first installed supersede all other 
agreements, whether they are written or oral, between the parties concerning the particular subject matter. The language of this Agreement shall for all purposes be 
construed as a whole, according to its fair meaning, not strictly for or against either party, and without regard to the identity or status of any person who drafted all or 
any part of it. No purchase order or any other purchasing instruments issued by Customer, even if such purchase order or other purchasing instrument provides that 
it takes precedence over any other agreement between the parties, shall be effective to contradict, modify, delete from or add to the terms of this agreement in any 
manner whatsoever.
5. Severability. In the event that any one or more provisions of this Agreement is found by a court of competent jurisdiction to be unenforceable or invalid, then 
notwithstanding any such finding the remainder of this Agreement shall remain in full force and effect, and such provision that is found to be unenforceable or invalid 
shall be deemed severed. 
6. Waiver. Neither party’s right to require performance of the other party’s obligations hereunder shall be affected by any previous waiver, forbearance, or course of 
dealing, nor shall any waiver or forbearance or other course of dealing at any time with respect to any term or condition in this Agreement be effective unless evidenced 
in writing signed by the waiving party as to such waiver, forbearance or other course of dealing. No waiver or modification of this Agreement or any covenant, condition 
or limitation herein contained shall be valid and no evidence of waiver or modification shall be offered or received in evidence in any proceeding, arbitration or litigation 
between the parties hereto arising out of or affecting this Agreement or the rights or obligations of the parties hereunder, unless such waiver or modification is in writing 
duly signed by both parties.
7. Headings, Sections - The various headings in this Agreement are inserted for convenience only and shall not affect the meaning or interpretation of this Agreement or 
any Section or provision hereof.
8. Disputes; jurisdiction and venue. Customer and MINISOFT consent to personal jurisdiction, subject matter jurisdiction, and venue in the state and/or federal courts 
sitting in King or Snohomish Counties, State of Washington. Any action relating to this Agreement must be brought in the state or federal courts located in King or 
Snohomish County, Washington.
9. Attorney’s Fees. In the event legal action is brought by either party to enforce any of the provisions of this Agreement, the prevailing party shall recover its reasonable 
attorney’s fees, costs, and expenses, including but not limited to fees, costs and expenses of collecting any judgment.
10. Export. The export of this product is restricted by U.S. export regulations.
11. GOVERNMENT RESTRICTED RIGHTS. The Software Product and documentation are provided with restricted rights. Use, duplication or disclosure by the 
Government is subject to restrictions as set forth in subparagraph (c) (2) (ii) of the Rights in Technical Data and Computer Software clause at DFARS 252. 227-7013 or 
subparagraphs (c) (1) and (2) of the Commercial Computer Software-Restricted Rights at 48 CFR 52.227-19, as applicable. Contractor/manufacturer is MINISOFT, INC., 
1024 FIRST STREET, SNOHOMISH, WASHINGTON, 98290, U.S.A.
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Introduction
The Document Template can create forms that move with incoming data or can be 
used in conjunction with creating HTML output. For example, a dynamic form can take 
a standard text file output and turn it into a custom order confirmation that may be 
emailed to a client. The customized dynamic forms for HTML output can be customized 
with urls, links, pictures, and tables:
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SECTION 1

Dynamic forms can also be used to create free-flowing forms. Free-flowing forms 
contain headings that move with data based on how much data is contained within the 
data file:
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Implementing a Dynamic Form

1. Create a new project that includes a page and blank form using the default 
settings:

 

 

NOTE:  Since we will be creating variables and rules to reposition the data 
dynamically, when the Form Properties appears, select Exclude Data 
from the General tab.

2. Open the data file you would like to use to create your dynamic form. The data will 
appear in the Data Viewer.
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SECTION 1

3. Assign the necessary variables you would like to add to your dynamic form:

 



Overview

13

Basics
Variables

A Variable stores data for later use for Rules, Functions, Procedures and Conditions. Any 
one Variable can be used multiple times within a particular project. eFORMz has the 
ability to add variables based on a position or node value (xml).

Variables by Position

To create a Variable based on a specified position in the Data Viewer:

1. From the top pane of the eFORMz Viewer, the Input Data Viewer, select a string 
of characters with your mouse (left click + drag), right mouse click and select Add 
Variable.
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SECTION 1

2. The Variable dialog box will display. Enter a name and click OK to proceed.

 

Variables using Data Node

Create Variables from XML nodes. 

1. To create a Variable, right click a data node and select Add Variable. 

 



Overview

15

2. The Variable dialog box will display. Click OK to continue.
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SECTION 1

Components

A Document Component is a descriptor that defines particular layout properties. There 
are four Document Components: Paragraphs, Tables, Boxes and External Document 
Templates.

Paragraph
1. To add a Paragraph, right click the form and select Add Document Component > 

Paragraph. 

 

NOTE:  Paragraphs can be added to a Table. The result is to create a Row for 
each line in the Paragraph.
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2. The General tab of the Paragraph Properties dialog box will display.

 

3. To adjust the Background Color, uncheck the Automatic box and left click the color 
bar. The Background Color dialog box will display. Select one of the Swatches or 
create a custom color with HSB or RGB.  
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SECTION 1

4. Navigate to the Font tab. To adjust the Background Color, uncheck the Automatic 
box and left click the color bar. The Background Color dialog box will display. Select 
one of the Swatches or create a custom color with HSB or RGB.

 

5. Next, navigate to the Borders tab. 

 



Overview

19

6. The adjacent tab is for Margins. 

  

7. Select the Padding tab. When complete, click OK. 
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Table

To add a Table:

1. Right click the form and select Add Document Component > Table. 

  

2. The General tab of the Table Properties dialog box will display.
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3. Navigate to the Font tab.

  

4. From there, select the Borders tab. 
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SECTION 1

5. Navigate to the Margins tab. When complete, click OK. 

 

6. Navigate to the Descriptions tab. Enter a value that describes the contents of the 
Table.
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7. Next, right click the Table and select Add Row.

 

8. The Row Properties dialog box will display. Navigate to the Font tab if necessary. 
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SECTION 1

9. Make any modifications to the font. If adding a description for the Row, navigate to 
the Description tab. When complete, click OK. 

  

10. Make any modifications to the font. If adding a description for the Row, navigate to 
the Description tab. When complete, click OK. 
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11. Right click the Row and select Add Cell.

  

12. Make any modifications to the cell width, color, font, borders and padding as seen 
fit. When complete, click OK.
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Box
1. Right click the form, highlight Add Document Component and pick the Box option.

 



Overview

27

2. The General tab of the Box Properties dialog box displays.

 

3. Navigate to the Font tab.
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4. Select the Borders tab.

 

5. Move to the Margins tab.
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6. Navigate to the Padding tab. .

   

7. Finally, move to the Description tab. When finished, click OK.
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SECTION 1

Elements
Document Elements are part of a Document Component. A Document Element can be 
dynamic or static content, such as Text, Variables or Barcodes. 

Adding Text

Text Value
1. Right click a Paragraph Component and select Add text > Text value.

 

2. Enter a value into the Text field.

 

3. To modify the Text Color, uncheck the Automatic button and left click the color bar 
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next to it.

 

4. Select from one of the Swatches or create a custom color. When complete, click 
OK.
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Variable Value
1. Right click a Paragraph Component and select Add text > Variable value.

 

2. Select a Variable from the Variable drop-down menu and navigate to the Font tab.
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3. Make any necessary modifications. To adjust the color, uncheck the Automatic box 
and left click the color bar next to it. 

 

4. Select from one of the Swatches or create a custom color. When complete, click 
OK.
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Special Font
1. Right click a Paragraph Component and select Add text > Special font.

 

2. Enter a Constant value or select a Variable from the Variable drop-down menu. Pick 
the Special font type from the drop-down menu and click OK. 
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Page number
1. Right click a Paragraph Component and select Add text > Page number.

 

2. Select the Page number type from the drop-down menu. This will place the page 
number of a form or document based upon the number of pages it contains or 
its location within a series of pages. Options include Page number within group, 
Number of pages in group, Page number within document and Page number in 
document. The Starting Page property determines the number of the first page 
placed. The Default is 1. Switch to the Font tab when done.
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3. Make any necessary modifications. To adjust the color, uncheck the Automatic box 
and left click the color next to it.
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Adding Barcodes

1D Barcode
1. To add a 1D Barcode, right click a Paragraph Component and select Add barcode > 

1D barcode.

 

2. Select the Variable from the drop-down menu or enter a Constant value. Select the 
Barcode type and make any necessary configuration adjustments. Click OK when 
complete. 
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2D Barcode
1. To add a 2D Barcode, right click a Paragraph Component and select Add barcode > 

2D barcode.

 

2. Select the Variable from the drop-down menu or enter a Constant value. Select the 
Barcode type and make any necessary configuration adjustments. Click OK when 
complete.
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Adding Images

Images from Project

To import an Image into a project for use with a Dynamic Template:

1. Right click the project and select Properties > Images.
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SECTION 1

2. Select the Add button and choose an Image. Once the Image is imported into a 
project, it will remain with that project until it is manually removed. Click OK when 
complete.

 

3. To add an Image from a project, right click a Paragraph Component and select Add 
image > Image from project.
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4. Select an Image from the Image from Project drop-down menu. Click OK.
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Image from file
1. To add an Image from file, right click a Paragraph Component and select Add image 

> Image from file.

 

2. In the Image from File field, select the browse button (...) and pick the appropriate 
Image.
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Image from file using variable
1. To add an Image from file using a Variable, right click a Paragraph Component and 

select Add image > Image from file using variable.

 

2. From the Variable containing image file name field, select the appropriate Variable. 
Make any necessary adjustments and click OK. 
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SECTION 1

Image from PDF file
1. To add an Image from a PDF file, right click a Paragraph Component and select Add 

image > Image from PDF file.

 

2. In the Image from PDF File field, select the browse button (...) and pick the 
appropriate Image. Make any necessary modifications and click OK.
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Image from PDF file using variable
1. To add an Image from a PDF file using a Variable, right click a Paragraph 

Component and select Add image > Image from PDF file using variable.

 

2. From the Variable containing PDF file name field, select the appropriate Variable. 
Make any necessary adjustments and click OK. 
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Image from URL
1. To add an Image from a URL, right click a Paragraph Component and select Add 

image > Image from URL.

 

2. Enter the URL in the Image from URL field. Make any necessary alterations and 
click OK.
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Image from URL using variable
1. To add an Image from a URL using a Variable, right click a Paragraph Component 

and select Add image > Image from URL using variable.

 

2. From the Variable containing URL field, select the appropriate Variable. Make any 
necessary adjustments and click OK.
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Image from component
1. To add an Image from a URL using a Variable, right click a Paragraph Component 

and select Add image > Image from URL using variable.
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Adding Line Breaks and Links

Line break
1. To add a Line break, right click a Paragraph Component and select Add > Line 

break.

 

Link
1. To add a Link, right click a Paragraph Component and select Add > Link.
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SECTION 1

2. Enter the URL or select a Variable which contains the relevant URL. Checking the 
Display in new browser window box will ensure that when the Link is selected, it 
will pop up in a new window. The default is unchecked. 

 

3. To add a Document Element that will be linked, right click the Link and select a 
Document Element.
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Creating a Dynamic  
Document Template

The following example will demonstrate the process of implementing a dynamic 
document template to create an HTML output file.

NOTE:  To successfully output in HTML format, make sure the incoming data is 
excluded, a blank form is used, there aren’t any constants or rules and 
the same number of cells are used in each row. 
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Adding an Image

To include an image on a dynamic form, for example, if you would like to include a 
company logo:

1. Right click your form and select Add Document Component > Paragraph:

 

2. The Paragraph Properties dialog box will display. Select OK.

3. To the Paragraph element we are going to add an image. An image can be added in 
one of the following ways:

 Image from >  
  Project 
  Image From File 
  Image From File using variable 
  PDF file 
  PDF file using variable 
  Image URL 
  Image URL using variable

 For this example we are going to add an Image from a URL address.
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4. From the Paragraph element select Add > Image from URL:

 

5. The Properties dialog box displays. Enter the URL address for retrieving your 
image:

 

 

TIP:  Calling an image from a URL for email HTML output allows an email to 
be attachment free. 
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NOTE:  Values are in decipoints. 1 pixel = 7.5 decipoints.

6. Your image will now appear in the Form Viewer:
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7. Before adding the next element, an adjustment can be made to the paragraph 
containing the image element. For example, we would like to add padding to the 
paragraph so that the text following the image will be spaced apart from the image 
element.

 From the Paragraph element, right click, select Edit > Padding:
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8. The next element to be added is a text paragraph. To add a text paragraph, right 
click your Document Template and select Add Document Component > Paragraph.

 Note: A new paragraph component could have been added to the existing 
paragraph that contains the image logo, but since padding had been set for this 
component a new component that does not have padding specified will be added.
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9. Right click Paragraph and select Add > Text Value.
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10. The Text Properties dialog box will display. Enter your contents:

 

For this example we will add the clients name to the opening comments. To dynamically 
implement this new variable content segment to the opening comments, perform the 
following:

11. Select the Paragraph segment you would like to add the variable to, right click, and 
select Add > Variable value:
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12. The Content Segment dialog box displays. Select the Variable you would like to add 
to your Paragraph element:

  

13. As your project develops you will come to have multiple content elements with 
variables or image segments.
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Creating a Table
To add a table to your Document Template:

1. From the Document Template, right click, and select Add Document Component > 
Table:

 

2. The Table Properties dialog box displays:

 

For this example, a table with 2 rows and 3 columns will be created. The second row 
will contain variables that format the specified data into columns. Qty, Item Number, 
and Item Description are the column headings. Create the first table row with these 
headings:
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1. From the Table element, right click and select add row. Once a row has been added 
create the three new cells that will contain your column headings:

 

2. Once the cells have been created a Paragraph element will need to be added along 
with a Content Text which will allow you to create the headings, as shown below:
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3. To create the second row, simply copy the previous row as shown below. You can 
then remove the Content elements so that you can now implement the different 
variable calls.  

 

TIP:  To create a copy of your previous row, select the row you would like to 
copy, hold down your CNTL key and then begin to drag the selection. 
Drag the selection and let go of your mouse and CNTL key. Dragging 
your selection will display a black horizontal line followed by two plus 
symbols. Once the below is seen, let go of your mouse:

 

4. Next, add each variable to their respective headings. From the Paragraph element, 
right click and select Variable value:
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5. When the Value Content Segment Properties dialog box displays, select the 
variable you would like to place in this column.

 

6. Once your variables have been added they will immediately start appearing in your 
table:
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7. As your project begins to build you will see results like the following:
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Advanced

Input Fields

Available input field types include:

♦ Check Box

♦ Combo Box

♦ List Box

♦ Push Button

♦ Radio Group

♦ Text Area

♦ Text Box

♦ State Button

♦ Selection Button 

♦ Hidden Field
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Check Box

General Tab

Name
Input data field name. 

Width
Text box width in decipoints.

Height
Text box height in decipoints.

Opaque
If set, the control will have an opaque background the color of the “Background Color” 
property, otherwise, the control will be transparent.

Background Color
Text box background color.

Enabled
(Default checked) When unchecked, the text box input field will become shaded.
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Include in tab order
(Default checked) If kept checked, this option will include the text box in a tab order 
determined by the order the fields are defined in the project file.

Event Enabled
(Default unchecked) If checked, the field is enabled for the creation of change-based 
rules.

Tip Text
Include a text tip when the mouse scrolls over the text box input field.

Vertical Alignment
Options include baseline, top, middle, and bottom.

Options Tab

Label
The text that will be displayed next to the check box.

Initial State
Indicates whether the check box is to appear checked or unchecked.
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ComboBox

General Tab

Name
Input data field name. 

Width
Text box width in decipoints.

Height
Text box height in decipoints.

Opaque
If set, the control will have an opaque background the color of the “Background Color” 
property, otherwise, the control will be transparent.

Background Color 
Text box background color.

Enabled
(Default checked) When unchecked the text box input field will become shaded.
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Include in tab order
Check this option if you would like to include the text box in a tab order determined by 
the order the fields are defined in the project file.

Event Enabled 
(Default unchecked) If checked, the field is enabled for the creation of change-based 
rules.

Tip Text 
Include a text tip when the mouse scroll over the text box input field.

Vertical Alignment 
Options include baseline, top, middle, and bottom.

Data Tab

Values
List of data items that can be selected from a drop-down list.

Value
The text that will initially be displayed in the combo box field.
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Options Tab

Editable
Enables the user to enter a value into the combo box field to perform a search. Note 
that options must be in alphabetical order.

Auto Popup 
Displays the list of values to choose from in the combo box. Note that options must be 
in alphabetical order.

Input Length 
Limits the number of characters displayed in the combo box after an item has been 
selected.

List Size 
Limits the number of items displayed in the combo box.

Auto tab when full
Once the combo box has reached the specified limits, an auto tab to the next item will 
be issued.

Select on focus 
Causes the text in the field to be selected (highlighted) when a field gets the focus.
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ListBox

General Tab

Name
Input data field name. 

Width
Text box width in decipoints.

Height
Text box height in decipoints.

Opaque
If set, the control will have an opaque background the color of the “Background Color” 
property, otherwise, the control will be transparent.

Background Color 
Text box background color.

Enable
(Default checked) When unchecked the text box input field will become shaded.
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Include in tab order 
Check this option to include the text box in a tab order determined by the order the 
fields are defined in the project file.

Event Enabled 
(Default unchecked) If checked, the field is enabled for the creation of change-based 
rules.

Tip Text 
Include a text tip when the mouse scroll over the text box input field.

Vertical Alignment 
Options include baseline, top, middle, and bottom.

Data Tab

Choices
List of items by which the user can select from.

Single Selection
Check box permitting the selection of only one item from the list of choices.
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Values
Data placed in document corresponding to the user selected index(es). Note, if there 
are no items in “Values” then the items in “Choices” is used.

Value
Allows one to specify the initial selection(s) of the ListBox field.

Max Output Lines 
Set the number of line the value of the input field will take when in .efd format and used 
as a data file.
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PushButton

General Tab

Name
Input data field name.

Width
Text box width in decipoints.

Height
Text box height in decipoints.

Opaque
If set, the control will have an opaque background the color of the “Background Color” 
property, otherwise, the control will be transparent.

Background Color 
Text box background color.

Enable
(Default checked) When unchecked the text box input field will become shaded.
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Include in tab order
Check this option to include the text box in a tab order determined by the order the 
fields are defined in the project file.

Event Enabled 
(Default unchecked) If checked, the field is enabled for the creation of change-based 
rules.

Tip Text 
Include a text tip when the mouse scroll over the text box input field.

Vertical Alignment
Options include baseline, top, middle, and bottom. 

Options Tab

Label
Information displayed in the input field.

Alignment
Option to align the label fields (left, right, or center).

Mnemonic key
Value associated with a drop down list of pre-defined instructions.
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RadioGroup

General Tab

Name
Input data field name. 

Width
Text box width in decipoints.

Height
Text box height in decipoints.

Opaque
If set, the control will have an opaque background the color of the “Background Color” 
property, otherwise, the control will be transparent.

Background Color
Text box background color.

Enable
(Default checked) When unchecked the text box input field will become shaded.

Include in tab order
Check this option to include the text box in a tab order determined by the order the 
fields are defined in the project file.
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Event Enabled 
(Default unchecked) If checked, the field is enabled for the creation of change-based 
rules.

Tip Text
Include a text tip when the mouse scroll over the text box input field.

Vertical Alignment 
Options include baseline, top, middle, and bottom. 

Data Tab

Labels
List of data items by which the user can select from.

Values
Representation of the data items corresponding to the choice(s) selected.

Value
Select a value from the Value list that will be the default selected item.

Orientation
Displays choices vertically or horizontally across the form. 
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Text Area

General Tab

Name
Input data field name. 

Width
Text box width in decipoints.

Height
Text box height in decipoints.

Opaque
If set, the control will have an opaque background the color of the “Background Color” 
property, otherwise, the control will be transparent.

Background Color
Text box background color.

Enable
(Default checked) When unchecked the text box input field will become shaded.
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Include in tab order
Check this option to include the text box in a tab order determined by the order the 
fields are defined in the project file.

Event Enabled
(Default unchecked) If checked, the field is enabled for the creation of change-based 
rules.

Tip Text 
Include a text tip when the mouse scroll over the text box input field.

Vertical Alignment
Options include baseline, top, middle, and bottom. 

Data Tab

Value
Text can be entered in this field which will be displayed when the form is first opened.

Select on focus
Causes the text in the field to be selected (highlighted) when a field gets the focus.

Display with border 
Includes a border around the input field.

Max. Output Line 
Set the number of lines the value of the input field will take when in .efd format and 
used as a data file.
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Text Box

General Tab

Name
Input data field name.

Width
Text box width in decipoints.

Height
Text box height in decipoints.

Opaque
If set, the control will have an opaque background the color of the “Background Color” 
property, otherwise, the control will be transparent.

Background Color 
Text box background color.

Enable
(Default checked) When unchecked the text box input field will become shaded.
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Include in tab order
Check this option to include the text box in a tab order determined by the order the 
fields are defined in the project file.

Event Enabled 
(Default unchecked) If checked, the field is enabled for the creation of change-based 
rules.

Tip Text 
Include a text tip when the mouse scroll over the text box input field.

Vertical Alignment 
Options include baseline, top, middle, and bottom. 

Options Tab

Value
Enter a value that will appear in the input field when it is viewed in eReader.

Input Length
Character length of the input field text box.
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Mode
(Default Normal) Options available are:

Normal - Allows you to enter any character into the value field when a eFORMz 
document file is produced.

Secure - Characters entered into the text box will appear as asterisks (****).

Display Only - Displays only the value entered in the Value field.

Auto Tab when full 
When a TextBox is full with the number of characters specified in the Input Length field 
an auto tab will be issued to the next input field.

Select on Focus 
Causes the text in the field to be selected (highlighted) when a field gets the focus.

Display with Border
Includes a border around the text box fields.
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State Button

General Tab

Name 
Input data field name. 

Width
Text box width in decipoints.

Height
Text box height in decipoints.

Opaque
If set, the control will have an opaque background the color of the “Background Color” 
property, otherwise, the control will be transparent.

Background Color 
Text box background color.

Enable
(Default checked) When unchecked the text box input field will become shaded.
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Include in tab order 
Check this option to include the text box in a tab order determined by the order the 
fields are defined in the project file.

Event Enabled
(Default unchecked) If checked, the field is enabled for the creation of change-based 
rules.

Tip Text 
Include a text tip when the mouse scroll over the text box input field.

Vertical Alignment 
Options include baseline, top, middle, and bottom. 

Options Tab

Selected Label
The text that will be displayed as the selected label.

Unselected Label 
The text that will be displayed as the unselected label.

Get Labels from URL
(Default unchecked) When checked, retrieves labels from a URL.

Initial State 
Indicates whether the check box is to appear checked or unchecked.
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Selection Button

General Tab

Name
Input data field name. 

Width
Text box width in decipoints.

Height
Text box height in decipoints.

Opaque
If set, the control will have an opaque background the color of the “Background Color” 
property, otherwise, the control will be transparent.

Background Color
Text box background color.

Enable
(Default checked) When unchecked the text box input field will become shaded.
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Include in tab order 
Check this option to include the text box in a tab order determined by the order the 
fields are defined in the project file.

Event Enabled 
(Default unchecked) If checked, the field is enabled for the creation of change-based 
rules.

Tip Text 
Include a text tip when the mouse scroll over the text box input field.

Vertical Alignment 
Options include baseline, top, middle, and bottom. 

Options Tab

Selected Label 
The text that will be displayed as the selected label.

Unselected Label 
The text that will be displayed as the unselected label.



Advanced

87

Get Labels from URL 
(Default unchecked) When checked, retrieves labels from a URL.

Initial State 
Indicates whether the check box is to appear checked or unchecked.

Select Value 
The visible value for the label. 

Value
The value for the label. 

Hidden Field

General Tab

Name
Input data field name. 

Width
Text box width in decipoints.
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Height
Text box height in decipoints.

Opaque
If set, the control will have an opaque background the color of the “Background Color” 
property, otherwise, the control will be transparent.

Background Color 
Text box background color.

Enable
(Default checked) When unchecked the text box input field will become shaded.

Include in tab order 
Check this option to include the text box in a tab order determined by the order the 
fields are defined in the project file.

Event Enabled
(Default unchecked) If checked, the field is enabled for the creation of change-based 
rules.

Tip Text
Include a text tip when the mouse scroll over the text box input field.

Vertical Alignment 
Options include baseline, top, middle, and bottom.
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Options Tab

Value
Select a value from the Value list that will be the default selected item.
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Cascading Style Sheets (CSS)

Often, transactional emails make use of Cascading Style Sheets (CSS), which define 
how to display HTML elements. This ensures brand consistency, as the look of any 
event-triggered message will reflect the company identity associated with the website. 
eDIRECT PLUS lets businesses create documents fully furnished with their style sheets 
by referencing them in the Document Template. 

1. To reference a style sheet, right click the Document Template, highlight Edit and 
choose the General option.

 

2. From the General tab, enter the URL for the desired style sheet in the CSS URL 
field.  Click OK to proceed.

  

NOTE:  The Output Style drop-down field contains two options: Implicit 
and Explicit. The Implicit option allows a style to be applied to all 
elements of matching type, while the Explicit option restricts a style 
only to individually specified types. 
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3. Right click a component or element and select Edit > Style ID.

  

4. Select the appropriate Id or Class from their respective drop-down menus. Click OK 
to continue.

 

5. The changes will display in the Form and Data Viewer.

Before:

 

After:

 

CSS basic_gray class being referenced:
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External Document Template

The eFORMz user may add a document template from an existing project file. The steps 
for creating a new project do not vary, but building the project requires less time. 

Once the form and data have been merged into an eFORMz Project, right click the form 
and select Add Document Component > External document template.
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1. The External Document Template Properties dialog box will display. Select the 
browse button in the project field to call an external document template from an 
eFORMz project file.

 

2. Locate and open the appropriate project.
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3. The project file and corresponding form(s) will display. Click OK to continue.

 

4. The external document template will have been successfully referenced.
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5. To add variable values to the external document template, create a variable by 
right clicking a string of characters and selecting Add variable.

 

6. Click OK.

 

7. Right click the External Document Template and select the Edit option.
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8. Match the particular variable value.

 

9. The variable will display based upon its placement in the external document 
template being referenced.
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External HTML File

eFORMz users are able to reference HTML files as templates for HTML output. The 
HTML template file is configured with the HTML Output tab in the Form Properties. 
Document components from the top level of a document template are merged with 
the HTML template by “Id,” matching the “ID=” parameter on a “<TABLE>,” “<P>,” or 
“<DIV>,” tag in the HTML template file. The template provides fixed information such 
as logos, while the document components in a document template fill in the dynamic 
information. 

To reference an external HTML template, navigate to the HTML Output tab in the Form 
Properties.
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1. Select the browse button for the HTML template file field.

 

2. Locate and open the HTML file to import.
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3. Enter a value in the Title field and click OK to proceed. If the Output inline styles 
box is unchecked, inline styles will not be outputted. 

 

4. To test the file, switch to the eDIRECT (or eDIRECT PLUS) tab. Right click in the 
Project window and select Add Output > E-Mail.
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5. Right click the E-Mail and select Add provider > JavaMail.

 

6. Enter the appropriate values for the relevant fields.
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7. Right click the E-Mail and choose the Add body option.

 

8. Right click the Body and select Add content > Generated.

 



102

SECTION 3

9. Choose the HTML format option.

 

10. Right click the Content and select Add Form(s).
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11. Pick the form that will be sent.

 

12. Navigate to the eFORMz Main Menu and select Run > Process w/eDIRECT (or 
eDIRECT PLUS).
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13. The HTML template file will be sent to the specified email address as an HTML 
email. With the external template reference, the document template in eFORMz 
can now be used to build the dynamic form elements. 
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Language Substitution

Within a Document Template, a single report can be utilized for multiple languages. 
Using Declared Constants and Keyed Declared Constants, different languages can be 
substituted automatically in document components. 

Use eFORMzCfg_Translations.xml and update the values accordingly. A sample 
configuration is shown below:

<?xml version=“1.0” encoding=“UTF-8”?>

<eFORMzConfiguration>

  <Constant Name=“OrderNbr_EN”>

   <![CDATA[Order Number]]>

  </Constant>

  <Constant Name=“OrderNbr_FR”>

   <![CDATA[French Order Nbr]]>

  </Constant>

  <Constant Name=“OrderNbr_GE”>

   <![CDATA[German Order Number]]>

  </Constant>

  <KeyedConstant Name=“OrderNbrLabels”>

   <Entry Key=“EN”>

    <![CDATA[Order Number]]>

   </Entry>

   <Entry Key=“FR”>

    <![CDATA[French Order Nbr]]>

   </Entry>

   <Entry Key=“GE”>

    <![CDATA[German Order Number]]>

   </Entry>

  </KeyedConstant>

</eFORMzConfiguration>
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In the eFORMzCfg_User.xml file, enter the eFORMzCfg_Translations.xml file name and 
its directory:

<File Name=“\Projects\Documentation\eFORMzCfg_Translations.
xml”/>

From there, a report built with the Document Template can be configured for language 
substitution. A sample report is shown below using three different methods.

1. First, create a Variable by right-clicking the Form and selecting Add Variable > By 
position.

 

2. Enter ‘Language’ in the Name field and select OK.
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3. Add another Variable by position. Enter ‘OrderNbrConstantName’ in the Name 
field. 

 

4. Right click the Variable and select Add Function > Set Value.
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5. Enter a Constant value of ‘OrderNbr_’ and select OK. 

 

6. Right click the Variable and select Add Function > Concatenate.

  

7. Select the Language Variable.

 



Advanced

109

Language Substitution Using a Set Value from a       Declared 
Constant Function

1. Add another Variable by position and enter the name ‘OrderNbrLabel.’

 

2. Right click the Variable and select Add Function > Set value from a declared 
constant.
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3. Select the ‘OrderNbrConstantName’ Variable. 

 

The ‘OrderNbrConstantName’ Variable has been set to ‘OrderNbr_’ and the 
concatenated value of the ‘Language’ Variable. This Variable is picking up the two-letter 
language code from the incoming data file. This corresponds to the format of the 
Declared Constants in the eFORMzCfg_Translations.xml file:

<Constant Name=“OrderNbr_EN”>
   <![CDATA[Order Number]]>
  </Constant>
  <Constant Name=“OrderNbr_FR”>
   <![CDATA[French Order Nbr]]>
  </Constant>
  <Constant Name=“OrderNbr_GE”>
   <![CDATA[German Order Number]]>

</Constant>

For example, if the language code is ‘FR’ then the value of ‘OrderNbrConstantName’ 
will be ‘OrderNbr_FR’ and the value of the ‘OrderNbrLabel’ Variable will be the French 
Order Number.
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Language Substitution Using a Set Value from a Keyed De-
clared Constant Function

1. Add another Variable by position and enter ‘OrderNbrLabel1’ in the Name field.

 

2. Right click the Variable and select Add Function > Set value from a keyed declared 
constant.

 



112

SECTION 3

3. Select the ‘OrderNbrLabels’ Keyed Declared Constant which was declared in the 
eFORMzCfg_Translations.xml. The Key Value should should be the Language 
Variable.

 

The Keyed Constant is as follows:
<KeyedConstant Name=“OrderNbrLabels”>
   <Entry Key=“EN”>
    <![CDATA[Order Number]]>
   </Entry>
   <Entry Key=“FR”>
    <![CDATA[French Order Nbr]]>
   </Entry>
   <Entry Key=“GE”>
    <![CDATA[German Order Number]]>
   </Entry>
 </KeyedConstant>

The two-letter language code from the incoming data file will be picked up by the 
Language Variable. This is the Key Value, or the ‘Entry Key.’ For example, if the 
language code is ‘FR’ then the value of the ‘OrderNbrLabel1’ Variable will be the French 
Order Number.
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Language Substitution Using a Load Variable From a Keyed 
Declared Constant Pre-condition Procedure

1. Add another Variable by position and enter ‘OrderNbrLabel2’ in the Name field.

 

2. Right click the Form and select Add Pre-condition Procedure > Load Variable from 
a Keyed Declared Constant.
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3. Enter a value for the Name field and select the System Variable ‘N/A’ from the Use 
variable drop-down menu.

 

4. Select the ‘OrderNbrLabels’ Keyed Declared Constant which was declared in the 
eFORMzCfg_Translations.xml. The Key Value should should be the Language 
Variable. The Variable should be the ‘OrderNbrLabel2’ Variable. 

 

The Keyed Constant is as follows:
<KeyedConstant Name=“OrderNbrLabels”>
   <Entry Key=“EN”>
    <![CDATA[Order Number]]>
   </Entry>
   <Entry Key=“FR”>
    <![CDATA[French Order Nbr]]>
   </Entry>
   <Entry Key=“GE”>
    <![CDATA[German Order Number]]>
   </Entry>
 </KeyedConstant>

The two-letter language code from the incoming data file will be picked up by the 
Language Variable. This is the Key Value, or the ‘Entry Key.’ For example, if the 
language code is ‘FR’ then the value of the ‘OrderNbrLabel2’ Variable will be the French 
Order Number.
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Testing the Report
1. Right click the Form and select Add Document Component > Paragraph. 

 

2. Right click the Paragraph and select Add text > Variable value. 
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3. Select the ‘OrderNbrLabel’ Variable from the drop-down menu.

 

4. Add Paragraphs for the ‘OrderNbrLabel1’ and ‘OrderNbrLabel2’ Variables.

 

5. Right click the Project and select Display Forms and Data.
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6. Right click the Project and select Display Forms and Data.

 

7. From there, right click the Form and select Properties > Test Data.

 

8. For testing purposes, enter the ‘FR’ language code in the Language field.
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9. The French order number will display.

 

NOTE:  Using a Load Variable From a Keyed Declared Constant Pre-condition 
Procedure is the preferred method for language substitution, especially 
when 3 or more languages are going to be used for the same report. 
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Index
Variable Options

Variable options include:

Name
Variable name as displayed in the project layout.

Horizontal/Vertical Position
The Variable location in decipoints (180 decipoints = 1/4 inch).

# of characters 
The number of characters included in a Variable.

Height
Variable height. Customizes the Variable line height. 

Repeat
The number of data lines that a Variable will pick up.

Increment line by
Enables the skipping of lines. A value of one (1) applies a Rule or a Function to every line 
selected, a value of two (2) applies a Rule or a Function to every other line, and so on. 

Copy original data to output 
(Default is unchecked) When checked leaves the selected characters in there original 
position in the eFORMz Viewer. 
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Include variable in XML output 
For use with eDIRECT output. The default is unchecked. If checked, Variable names can-
not include special characters such as !, @, $, *.

Use as a bookmark in PDF output 
Variable will be bookmarked for PDF file output. 

Variables Data Node Options

 

Variable options include:

Name
Variable name as displayed in the project layout.

Data Node 
The node location of the Variable in relation to parent or child elements in the data 
node tree.

Transfer method:

Normal (any child elements as array) 
(Default) Will display any child elements as their own array, or indexed row of data 
within the parent element. 

Count of child elements
Provides a count of the child elements contained within the parent element. 

Sum of child elements’ data 
Calculates the sum of the child elements’s data contained within the parent element. 

Concatenation of child elements’ data (comma delimited) 
Concatenates all of the child elements’s data contained within the parent element. 
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Each element’s value is delimited by a comma. 

Concatenation of child elements’ data (new line delimited) 
Concatenates all of the child elements’s data contained within the parent element. 
Each element’s value is delimited by a new line. 

Include variable in XML output 
For use with eDIRECT output. The default is unchecked. If checked, Variable names can-
not include special characters such as !, @, $, *.

Use as a bookmark in PDF output
Variable will be bookmarked for PDF file output.

Node Filter 
The Node Filter filters for an element’s descendants. It allows grandchildren and great-
grandchildren to be parsed out.



Index

123

General References 

Alignment

The alignment of the Paragraph. Options include Left, Centered, Right, Justified and 
None (Default). 

Background Color

The Automatic box, when checked, will adopt the color designated as the default color 
configuration. If unchecked, the color can be altered.

Borders

Single Border

Style
The drop-down menu has Solid, Double, Dotted and Dashed options. 

Thickness
Adust the thickness level in decipoints. 1 pixel is the equivalent of 7.5 decipoints. 720 
decipoints is the equivalent of 1 inch. 

Color
Left click the color bar to modify the border color. 

Separate borders

Top style
The drop-down menu that contains style options related to the top border.

Bottom style
The drop-down menu that contains style options related to the bottom border.
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Left style
The drop-down menu that contains style options related to the left border.

Right style
The drop-down menu that contains style options related to the right border. 

Box Propeties (General)

Positioning

Within Document
(Default) When checked, the position is set within the document. 

Absolute Positioning
When checked, the position is defined by horizontal and vertical position, by page. 

Horizontal/Vertical position
Sets the horizontal and vertical positioning. Values are in decipoints. 

Page
Options include First Page, Last Page, nth page, Every Page, First through nth page, 
nth through last page, First through nth to last page, and nth to last through last page 
followed by the specified page number. 

For example: 

♦ “First through nth page” where nth = 5, the box will display on the first five pages.

♦ “nth through last page” where nth = 5, all pages except the first 4 will display the 
box.

♦ “First through nth to last page” where nth = 5, all pages except the last 5 will 
display the box.

♦ “nth to last through last page”, where nth = 5, the box will display on the last 6 
pages.

Size

Height
The Automatic option will retain the default setting for Box height. The Fixed option will 
adjust the Box height to the value entered into the adjacent field.
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Width
The Automatic option will retain the default setting for Box width. the Fixed option 
will adjust the Box width to the value entered into the adjacent field. The Ratio option 
will adjust the Box width to be at least the value entered into the adjacent field while 
varying with other elements. 

Background Color

The Automatic box, when checked, will adopt the color designated as the default color 
configuration. If unchecked, the color can be altered by left clicking the color bar next 
to the Automatic box.

Cell Properties (General)

Cell Width 
The Automatic option will retain the default setting for Cell width. The Fixed option 
will adjust the Cell width to the value entered into the adjacent field. The Ratio option 
will adjust the Cell width to be at least the value entered into the adjacent field while 
varying with other Cells. 

Background Color 
The Automatic box, when checked, will adopt the color designated as the default color 
configuration. If unchecked, the color can be altered by left clicking the color bar next 
to the Automatic box.

Vertical Alignment 
Options include baseline, top, middle, and bottom. 

First line indent

The indentation of the first line in decipoints. 1 pixel is the equivalent of 7.5 decipoints. 
720 decipoints is the equivalent of 1 inch. 
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Font

The Font field contains the following options:

Automatic
(Default checked) Applies the default text configuration.

Character Set
Applies the selected character set from the drop-down menu for text values. 

Font
Applies the selected font from the drop-down menu for text values.

Chars per inch
Specifies the characters per inch of the text values. 

Height
Specifies the height of the text values. 

Bold
When checked, the text values are bolded.

Italic
When checked, the text values are italicized.

Text Color 
The Automatic box, when checked, will adopt the color designated as the default color 
configuration. If unchecked, the color can be altered.

Margins

Automatic Margins 
(Default) When checked, the configured settings will be implemented. When 
unchecked, individual Margins can be modified.

Top
Defines the top space between a border and other outer elements. 

Left
Defines the left space between a border and other outer elements. 
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Bottom
Defines the bottom space between a border and other outer elements. 

Right
Defines the right space between a border and other outer elements.

Padding

Automatic Padding 
(Default) When checked, the configured settings will be implemented. When 
unchecked, Padding can be modified.

Top
Defines the top space between border and element content.

Left
Defines the left space between border and element content. 

Bottom
Defines the bottom space between border and element content. 

Right
Defines the right space between border and element content. 

 

NOTE:  When elements need space between them, it is better to use 
Margins.  When an inner element, such as text, needs space between 
the parent element and itself, utilization of Padding is advised. 

Row Properties (General)

Use as

Normal row
(Default checked) The Row is to be used in its declared position in the table. 

Page header
When checked, acts as the first Row on the page when a table is split because of 
pagination.
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Page footer
When checked, acts as the last Row on the page when a table is split because of 
pagination.

Repeat using

No repeat
(Default) This setting will not repeat any instance of a Row in relation to a specified 
Variable or Constant value.

Constant
When checked, any instance of a Row will repeat in accordance with the given Constant 
value.

Repeat of variable
When checked, any instance of a Row will repeat in relation to the given Variable value.

Row Height

The Automatic option will retain the default setting for Row height. The Fixed option 
will adjust the Row height to the value entered into the adjacent field. The Minimum 
option will adjust the Row height to be at least the value entered into the adjacent field. 

Background Color

The Automatic box, when checked, will adopt the color designated as the default color 
configuration. If unchecked, the color can be altered by left clicking the color bar next 
to the Automatic box.
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